Negative Miles on a Vehicle's Odometer in the Database

Related Questions

  • Why is there a negative odometer listed on the Vehicle Edit page?

Applies To

  • MyGeotab
  • Bulk Edit Tool
  • Odometer

Cause

The device was previously plugged into a different vehicle and has an existing odometer offset.

Resolution

Remove the odometer offset using the bulk edit tool:

  1. Navigate to the Bulk Edit Tool
  2. Enter your credentials
    1. In the Server name field enter my.geotab.com
    2. In the Database field enter the name of your database
    3. Enter your email and password in the respective fields
  3. Click Device under the SELECT ASSET section
  4. Click OdometerOffset(KM) under the SELECT PROPERTIES TO EDIT section
  5. Type the device's serial number and set the offset to 0 (or an offset appropriate for the new vehicle) within the INPUT field by following the format below:
    • G91234567891|0
  6. Click Analyze
  7. If the OUTPUT box shows the serial number as OK, then click OK, otherwise correct any invalid input
  8. Click Submit to make the changes

Additional Information

To avoid this issue in the future, follow the steps in the following article when moving GO devices between vehicles: How To Move a GO Device Between Vehicles

Alternatively, use Automatic Vehicle Management to manage this process automatically. See: What is Automatic Vehicle Management?