User Cannot be Added to the Database with Error: "User already exists"

Symptoms

  • User cannot be added to the database
  • Error: "User already exists"
  • Error: "There is an existing user with this email. Please choose a different email."

Applies To

  • MyGeotab
  • Users

Cause

User already exists in the database. This may not be apparent for the following reasons:

  1. User has been made historical
  2. User belongs to group not accessible by user attempting to add a new user
  3. User has Authentication type of MyAdmin (Global User), while user performing action has Basic Authentication

Resolution

Try the following steps in order to determine the cause and resolution:

  1. See: User not visible in the database to find out if the user is historical. If they are historical and you would like to reactivate the user, see How To Reactivate a Historical User in MyGeotab
  2. If the above step was unsuccessful, see: Unable to see some vehicles or users in MyGeotab
  3. If the above step was unsuccessful, the user may have been created with the wrong authentication type, please contact Support for further assistance.