My vehicle is no longer reporting fuel data

Symptoms

  • Vehicle used to report fuel data
  • Fuel level values have not changed over one or more trips
  • Total fuel used (since telematics device install) diagnostic is no longer being reported at all

Applies To

  1. Total fuel used (since telematics device install)
  2. fuel report

Workaround

  1.  Replace device and/or harness.

Resolution

  1. Pinpoint the time frame when the vehicle stopped reporting data accurately by looking at the fuel measurements:
    1. Go to Engine & Maintenance > Engine and Device... > Measurements
    2. Select the vehicle and the diagnostic Total fuel used (since telematics device install) in the Options drop-down.
    3. Run the report over different time frames until you find the day when data stopped being reported or stopped changing.
  2. Check faults during that time frame to narrow down the cause:
    1. Go to Engine & Maintenance > Engine and Device... > Faults
    2. Select the vehicle and a date range.
    3. You may want to look at a window around the day found in step 1, such as a week or month before.
  3. If there are connection faults found indicating a problem with the device or harness, follow the standard troubleshooting steps.  Some of these are listed below in the Additional Notes section.
  4. If there are more serious faults indicating the device must be replaced, contact support.
  5. If the only fault on the day in question is a firmware update, contact support and share this information with them.

Cause

 When a vehicle stops reporting fuel data, it is most often because of a bad install or harness or device malfunction.  Standard troubleshooting including power cycling the device, securing the device with a zip tie, and replacing the harness may be the solution. You might want to double check if there was a plan change placed on the device. 

Additional Notes

Video explaining some troubleshooting steps:

https://www.geotab.com/video/troubleshooting-maximizing-device-uptime/

Specific faults to look out for:

Accelerometer calibration in progress (more driving required) 

Telematics device fault: GPS quality poor (bad device install or vehicle undercover)

Telematics device fault: problem communicating with engine - potential bad install - harness issue or device failure - intermittent connection detected on the engine communication bus and it is now in listen only mode