What are the minimum requirements for C# SDK?

Applies To

  • Geotab SDK
  • C#
  • .Net Framework
  • DLL

Answer

For the latest Checkmate Database Versions, .NET Standard 2.0 is required.

For Geotab SDK, at least .Net Framework 4.6.1 is required to support .NET Core SDK 2.0. 

Most up-to-date version of the Checkmate DLL can be found here. When you expand the "Dependencies" field, it will tell you which framework(s) are supported.

All compatible .NET platform versions can be found here.

Additional Notes

The purpose of .NET Standard is to harmonize libraries and provide support for other frameworks to work with each other.

Please note that .NET Core SDK 2.0 only works on Visual Studio versions 2017+ as mentioned here.

The latest .NET Samples are available here. These examples can be cloned and used for testing/development.