My Emailed Report has been disabled due to Performance issues

Symptoms

  • No email has been received from a scheduled report
  • Going to the Report page in MyGeotab an error can be seen under the Email Report Tab
    • The location is Administration -> Reports -> <Report Name> -> Email Report
  • The error message is: "This report was automatically disabled due to performance issues. It can be re-enabled, but it will still be subject to the performance monitoring that initially disabled it.If this happens again, it is likely that there is a problem with your report. Please contact support for help."

Applies To

  • MyGeotab
  • Reports

Cause

The size of the report has exceeded the 10 MB limit. The total number of emails sent in an hour per rule cannot exceed 1000. The total data usage of emails per hour cannot exceed 1000 MB. The total number of emails sent in an hour per report cannot exceed 1000.

Resolution

  • Trim the report down by eliminating any columns and tabs that are not needed.
  • Splitting your report into multiple reports.
  • Decrease the selected date range

Additional Notes

Ensure that unnecessary data is also eliminated from the hidden Data tab in the report.