Unable to see some vehicles or users in MyGeotab because of data access

Related Questions

  • Can't find vehicle/Can't find user
  • Why can't one of my other administrators see his vehicles?
  • Why can't I see a group of vehicles in my database?
  • Unable to see some vehicles or drivers on MyGeotab portal
  • Admin is unable to see drivers in the database
  • Why cant I see a vehicle I know is in the database?
  • Why is my device not showing on the vehicles page?
  • Why can I only see one group?

Symptoms

  • Unable to view certain users or vehicles or groups
  • No longer able to view some users on the database

Applies To

  • MyGeotab
  • Administration
  • Users
  • Data Access
  • Groups
  • Driver

Cause

  1. The user does not have Data Access set to Everything, and the asset they are trying to view is in a group that they do not have access to. A user can only see assets within groups that they have data access to.
  2. The user is a driver with Prevent driver access to shared data enabled.

Resolution

  • An Administrator on the database with access to Everything will need to edit either the affected user to change their data access

OR

  • Edit the users/vehicles that the user needs to see to place them in the same group as the user

OR

  • Turn off Prevent driver access to shared data for the user.

Additional Notes

  • A user that can see only a specific group or groups can not change their own data access to Everything
  • Only an Administrator with Everything data access can give other users access to Everything
  • If the user is in a child group, they will not have access to users or vehicles in a parent group. Check the group tree in the database for the group set up.
  • For additional information on editing user's groups, see the following article : How to assign users to groups