MyGeotab User's Date Format Settings Not Reflected in Report

Symptoms

  • User has date format settings set to anything other than dd/MM/yy on the User Edit page, while reports generated for this user list dates in the format dd/MM/yy

Applies To

  • Reports
  • Users
  • Date Format
  • MyGeotab

Cause

This is by design, as there is no way to change cell settings from MyGeotab to the Excel sheet without changing the report template.

Workaround

Create a custom report based off of the desired report with Excel cell settings changed to display the desired date format, and upload this report to MyGeotab.

Resolution

None available, as it is currently not possible to change cell settings from MyGeotab to the Excel sheet without changing the report template.

Additional Notes

A user's date format settings will only affect what the user sees in the MyGeotab UI.