Unable to verify edited drive logs

Symptoms

  • Driver is unable to verify edited drive logs

Applies To

  • Geotab Drive
  • MyGeotab
  • HOS
  • Duty Status Logs

Cause

Edited Logs that needed to be verified are older than 14 days.

Resolution

  1. Go to HOS
  2. Select Duty Status Logs > Search name and date.
  3. Click on the highlighted logs > verify logs