Reseller account unable to authenticate in a customer database using the MyGeotab SDK

Symptoms

  • Reseller account unable to authenticate in a customer database
  • When we are trying to authenticate a customer's database, we are getting error response from the API
  • Error: "Incorrect login credentials"
  • Error: "InvalidUserException"

Applies To

  • MyGeotab SDK
  • Authentication

Cause

Allow reseller access is turned off within the database System Settings.

Resolution

Reach out to the customer and have them turn on reseller access.

Additional Notes

How do I enable Reseller access?