GO device will not activate

Symptoms

  • Device will not activate

Applies To

  • MyGeotab
  • Device will not activate

Cause

Device is not in MyGeotab

Resolution

To add device in MyGeotab first, then plug the device in a known working vehicle and test drive the vehicle for 10 minutes in an open field with clear sky.

Additional Notes

If the device does not activate after test drive, please proceed with troubleshooting steps outlined here: Troubleshooting Guide