Avatar

Add-In Code Cached

0

Add-in code seems to be cached by the geotab servers and not pulling the most recent version of the add-in. This is fine for production code but is causing a large increase in our development time and troubleshooting. This seems to be the case on all users and machines.

Is there a way to disable caching for testing purposes?

For reference here is the script that is not providing most up to date add-in code: https://my{server_id}.geotab.com/{database}/RequiredScripts

Shane Graham

Please sign in to leave a comment.

5 comments

Avatar

Hello Shane,

Since I would require a link to your add-in/database, this needs to be investigated in a ticket.

Can you please make a ticket with Geotab Support if you are a reseller? Or if you are partnering with a Reseller, can you please contact your Reseller to make a ticket with Geotab Support regarding the issues you are facing?

 

0
Comment actions Permalink
Shivansh Singla 0 votes
Avatar

Have you tried testing/development using Add-In Generator. It makes local add-in development a breeze.

Did you try disabling browser cache in dev-tools?

I found using something like gulp-uncache helps when the production files get updated to make sure the new files are used (instead of browser cached).
Maybe we should add this by default to generator...
0
Comment actions Permalink
Steve Hansen 0 votes
Avatar

I also noticed something seems to have changed recently Steve. We use cache-busting techniques for CSS and javascript and that's always worked well. But the main HTML add-in file used to systematically be loaded fresh when it changed. Now, it's occurred a few times in the last few weeks that we pushed an updated HTML file and Geotab was still loading the old one from cache. It's a problem because we can't do anything about it, since Geotab loads it server-side and pre-processes it, nothing we can do from the browser to force it to load. We can't use cache busting URL manipulation either, otherwise we'd need to update the add-in code everywhere it has been deployed...

0
Comment actions Permalink
LP Papillon [d2go] 0 votes
Avatar

Thanks guys. We're looking into it. Will let you know when we have an update.

0
Comment actions Permalink
Steve Hansen 0 votes
Avatar

Hey guys,

We identified the issue server side with caching external content. Will be fixed in v5.7.1804.

Thanks,

Steve

1
Comment actions Permalink
Steve Hansen 1 vote